Opened 2 years ago

Closed 2 years ago

#1071 closed defect (fixed)

MS Merge: Doesn't work when an old annotation entry is used as one of the experiments

Reported by: sena Owned by: dbrentw
Priority: high Milestone: GRITS - 1.2 SR2
Component: MS merge Version: GRITS 1.2.x
Severity: major Keywords:
Cc: sena

Description

I tried to merge NGlycans-A and NGlycans-C from the demo workspace. I've opened NGlycans-A with the latest version but haven't opened NGlycans-C. I see the following exception in the log file and no merge report entry is created.

java.lang.NullPointerException

at org.grits.toolbox.entry.ms.annotation.glycan.report.handler.MSGlycanAnnotationReportAnnotationHandler.addExternalQuantAliasInfo(MSGlycanAnnotationReportAnnotationHandler.java:302)
at org.grits.toolbox.entry.ms.annotation.glycan.report.handler.MSGlycanAnnotationReportAnnotationHandler.createSimianMergeDialog(MSGlycanAnnotationReportAnnotationHandler.java:492)
at org.grits.toolbox.entry.ms.annotation.glycan.report.handler.MSGlycanAnnotationReportAnnotationHandler.execute(MSGlycanAnnotationReportAnnotationHandler.java:146)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:282)
at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:264)
at

Afterwards, I opened the NGlycans-C annotation entry and opened the annotation table and tried the merge again. Everything worked fine.

Change History (2)

comment:1 Changed 2 years ago by dbrentw

Resolution: fixed
Status: assignedreview

resolved in SVN revision [2959]

comment:2 Changed 2 years ago by sena

Status: reviewclosed

tested in version GRITS 1.2.3.5

Note: See TracTickets for help on using tickets.