Opened 2 years ago

Closed 18 months ago

#1100 closed defect (fixed)

Problem entering values for descriptors of type Date

Reported by: sena Owned by: sena
Priority: normal Milestone: GRITS - 1.2 SR2
Component: Sample management Version: GRITS 1.2.x
Severity: major Keywords:
Cc:

Description

From Yukie:
Here is another feedback after in-house test.

I think it will be nicer if the OK button become available soon after a date description selected.

<What a user did>

Select ‘Delivery date’ (same issue in ‘Dispatch date’) from Tracking in Sample meta-data.


<What happens>

OK button is not available



<Then a user further did>

Enter the date


<What happens>

OK button is still not available



<Then>

When the user delete all text from the ‘Value’ box, OK button activated.


Change History (2)

comment:1 Changed 2 years ago by sena

Resolution: fixed
Status: assignedreview

the problem is related to the value entered. If the date is not in valid format, there is no message but it does not accept the input.

I've added an explanatory error message if the date entered is not valid.

Same change is made for invalid double values as well.

In revision [3184]

comment:2 Changed 18 months ago by sena

Status: reviewclosed
Note: See TracTickets for help on using tickets.