Opened 6 years ago

Closed 5 years ago

#666 closed defect (fixed)

MS editor: Error loading MGF based files

Reported by: Rene Ranzinger Owned by: dbrentw
Priority: normal Milestone: GRITS - 1.2
Component: MS data management Version: GRITS 1.1.x
Severity: major Keywords:
Cc: dbrentw

Description

Agilent data (LC/MS) was exported to MGF (include peak picking) and subsequently converted to mzXML or mzML (msConvert). These files can not be loaded.

See attached data files.

Attachments (1)

MGF.zip (86.7 KB) - added by Rene Ranzinger 6 years ago.

Download all attachments as: .zip

Change History (14)

Changed 6 years ago by Rene Ranzinger

Attachment: MGF.zip added

comment:1 Changed 6 years ago by Rene Ranzinger

Looking at the files in more detail the problem is probably these lines "PEPMASS=700.48 138747". It seems that the numbers (both!) are interpreted as precursor m/z in mzXML and mzML.

comment:2 Changed 5 years ago by Rene Ranzinger

Owner: set to dbrentw
Status: newassigned

comment:3 Changed 5 years ago by Rene Ranzinger

Milestone: GRITS - 1.1 SR1GRITS - 1.1 SR2

comment:4 Changed 5 years ago by dbrentw

Status: assignedaccepted

comment:5 Changed 5 years ago by dbrentw

Resolution: fixed
Status: acceptedreview

Resolved in SVN revision 1971

comment:6 Changed 5 years ago by Rene Ranzinger

Resolution: fixed
Status: reviewassigned

Loading this file as LC/MS data will work although it complains about not being able to generate a spectra tab for the overview and MS1. After annoting the data (which works) the overview opens (with artefical scan 0) => double click => empty tables (structure annotation and MS scans although there are scan).

Since this very specific data looks like TIM data (no MS1s) I tried uploading it as such but that failed with a lot of NumberFormatExceptions.

comment:7 Changed 5 years ago by dbrentw

Resolution: fixed
Status: assignedreview

Resolved in SVN revision 2079. You have to process this data as TIM or it won't work (no MS1)

comment:8 Changed 5 years ago by Rene Ranzinger

Priority: highestnormal
Resolution: fixed
Severity: blockermajor
Status: reviewassigned

TIM: That will work for the upload.

However there is still something not right. When I am open the MS entry and go the MS2 scans the peaklists are empty. Same goes if I open the summary few for a MS2 scan. The structures are there (pre-cursor annotation) but there is no peaklist.

comment:9 Changed 5 years ago by dbrentw

Status: assignedaccepted

comment:10 Changed 5 years ago by dbrentw

Resolution: worksforme
Status: acceptedreview

Please update and try again. You will have to re-run GELATO, but this works for me.

comment:11 Changed 5 years ago by Rene Ranzinger

Resolution: worksforme
Status: reviewassigned
  • Double click on MS entry => Opens the table with scan 0 that has 74 subscans
  • Double click on Scan 0 => List of MS2 scans
  • Double click on Scan 2 (precursor 983.2) => Open MS2 scan
  • Go to the peaklist tab => empty

Same is happening for the MS annotation. Precursor is there but MS2 peaks are not

In addition we lost the first scan in the data file (precursor 700.48). It does not show up in the MS2 list at all.

comment:12 Changed 5 years ago by dbrentw

Resolution: fixed
Status: assignedreview

resolved in svn revision 2114

comment:13 Changed 5 years ago by Rene Ranzinger

Status: reviewclosed
Note: See TracTickets for help on using tickets.