Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#815 closed defect (duplicate)

Exception when running GELATO but not keeping window active

Reported by: dbrentw Owned by: Rene Ranzinger
Priority: normal Milestone: GRITS - 1.2
Component: GRITS core Version: GRITS 1.1.x
Severity: major Keywords:
Cc:

Description

Exception:
java.lang.IllegalStateException: Application does not have an active window

at org.eclipse.e4.ui.internal.workbench.ApplicationPartServiceImpl.getActiveWindowService(ApplicationPartServiceImpl.java:36)
at org.eclipse.e4.ui.internal.workbench.ApplicationPartServiceImpl.findPart(ApplicationPartServiceImpl.java:92)
at org.grits.toolbox.core.service.impl.GritsUIService.openEntryInPart(GritsUIService.java:66)

is thrown and the MS editor fails to open when I run GELATO on an MS file but then begin working on something else.

Change History (4)

comment:1 Changed 4 years ago by dbrentw

Milestone: GRITS - 1.2 SR1
Status: newassigned

comment:2 Changed 4 years ago by sena

Resolution: duplicate
Status: assignedreview

This is the duplicate of ticket #799.

comment:3 Changed 4 years ago by Rene Ranzinger

Status: reviewclosed

comment:4 Changed 4 years ago by Rene Ranzinger

Milestone: GRITS - 1.2 SR1GRITS - 1.2
Note: See TracTickets for help on using tickets.