Opened 3 years ago

Closed 2 years ago

#903 closed defect (worksforme)

MS Editor: Cancel opening files can not be deleted

Reported by: Rene Ranzinger Owned by: dbrentw
Priority: normal Milestone: GRITS - 1.2 SR2
Component: MS data management Version: GRITS 1.1.x
Severity: major Keywords:
Cc: sena

Description (last modified by Rene Ranzinger)

  • double click MS entry
  • Cancel the opening operation (e.g. for later MS runs)
  • Try deleting the MS entry => Error message that files are used by other process (java.nio.file.FileSystemException)

It seems that there is lock on the files that does not get release when the opening process is canceled.

More problems: After the error was shown the entries are still present in the project Explorer (makes sense). After restarting the application the entries are gone but the MS files are still there.

Change History (7)

comment:1 Changed 3 years ago by Rene Ranzinger

Owner: set to sena
Status: newassigned

comment:2 Changed 3 years ago by Rene Ranzinger

Description: modified (diff)

comment:3 Changed 3 years ago by sena

Owner: changed from sena to dbrentw

It looks like we need a "closeFiles()" or similar API in org.systemsbiology.jrap.grits.stax.MSXMLParser to release opened files in case MzXmlReader is canceled

comment:4 Changed 2 years ago by Rene Ranzinger

Milestone: GRITS - 1.2 SR1GRITS - 1.2 SR2

comment:5 Changed 2 years ago by dbrentw

Status: assignedaccepted

comment:6 Changed 2 years ago by dbrentw

Resolution: worksforme
Status: acceptedreview

This may have been fixed along with other implementation. I can't reproduce at this point

comment:7 Changed 2 years ago by sena

Status: reviewclosed

closing this since we cannot reproduce

Note: See TracTickets for help on using tickets.