wiki:MigrationToJava1_9_and_Oxygen

Version 1 (modified by sena, 4 years ago) (diff)

--

==Problems experienced when using Eclipse Oxygen with Java 1.9==

  • Subclipse complains with Eclipse Oxygen - solution: install slikSVN: https://slicksvn.com/download
  • Eclipse shows compilation errors for all java.xml.bind, javax.xml imports (seems to be a display problem) but GRITS still runs without issues
    • manually changing the java execution environment isModular (by adding required modules) fixes the compilation error display but has to be done for each plugin??
  • Archive plugin does not work. Exception org.eclipse.swt.layout.GridData cannot be cast to FillData
  • GRITS product export does not work although launching it works fine within eclipse. There is a conflict about a batik.css version. Missing requirement: Eclipse CSS Core Support 0.12.101.v20170712-1547 (org.eclipse.e4.ui.css.core 0.12.101.v20170712-1547) requires 'bundle org.apache.batik.css 1.7.0' but it could not be found. See https://www.eclipse.org/forums/index.php/t/1089988/ for description of the same problem. Eclipse Oxygen seems to use batik 1.8 internally but its core plugin requires batik 1.7.0??