Changes between Version 2 and Version 3 of pureE4_branch_notes


Ignore:
Timestamp:
10/14/2016 09:57:18 PM (4 years ago)
Author:
sena
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • pureE4_branch_notes

    v2 v3  
    2121
    2222org.eclipse.ui package dependencies should be removed from plugin.xml. org.eclipse.ui.forms are still being used.
     23
     24== org.eclipse.ui.dialog.ListDialog ==
     25
     26This dialog is being used in several plugins (qrtpcr, experimentdesigner and others) and does not have any 3.x components but requires the dependency to "org.eclipse.ui" be kept even for pure E4 application
     27
     28== org.eclipse.ui.dialog.ListSelectionDialog ==
     29
     30This dialog still has some 3.x components but it is being migrated to E4 as tracked in the following bugs:
     31
     32https://bugs.eclipse.org/bugs/show_bug.cgi?id=446652
     33
     34https://bugs.eclipse.org/bugs/show_bug.cgi?id=446616